那个@终于要消失了

http://blog.jquery.com/2009/01/05/help-test-jquery-13-beta-2/
jQuery 1.3 beta2 发布了,当然好多天以前的事情了。就等14日正是发布了。
这意味着从jQuery 1.1开始带来的的@终于要被废除了。原因很简单,用了新的Sizzle引擎了嘛,要一个独立的引擎来支持另一个使用他的脚本库的老版本,始终不现实。
这也意味着,网络上流行的教程在最新的版本中将行不通了。(感觉跟Python升级到3.0后的print变成了函数一样的感觉……)
实际上我至今还看到国内有很多新手在使用[@type=checkbox][@checked]之类的选择器而不使用:checkbox:checked这种1.2版以后的选择器。
这方面还需要各位前辈多多推广才行。
如果能联系到
http://www.k99k.com/jQuery_getting_started.html
这里的网站管理者的话,希望能够在这个国内最广为流传的入门教程底下,加上一两句提醒的话,告知新手,这份教程中哪些地方在1.3版中不适用了。凡请转告一下吧。
而其他转载了这篇入门教程的同学看到了的话,也最高改一下自己的版本(虽然我知道这样不厚道,但为了“下一代” 麻烦改一下吧。^_^)

另外很高兴看到,在这版中的live可靠很多,不像上一版中,如果选择器使用 #id>span 这种,就报错了。这回就很好用了。相信1.3正式发行的时候会很好用的。

http://blog.jquery.com/2008/12/31/jquery-ui-16rc3-its-getting-really-close/
另外,这里说jQuery UI 1.6rc4发布了(rc3里的datepicker有重大bug)。有关注这方面的同学可以看看,当然,jQuery UI的文档一直是个大问题要感谢Cloudream同学,他为现在身为jQuery UI文档组成员,一直为其文档做出重要的贡献!(真期待哪天弄个中文版出来就更好了……恩^_^)

《那个@终于要消失了》有8个想法

  1. 囧,别这么说嘛,我就是负责文档的……|||

    除了callback里的ui参数返回的内容没有说明,针对稳定版的文档没什么大问题吧?该有的参数说明都有了,新版demo也几乎针对每个参数都有demo效果了,新的文档会捆绑到demo页面,但内容上来说,恐怕不会和现有版本有太大区别。另外,会放出一个themeroller切换主题插件,在用themeroller的页面引入一个JS就可以用伪下拉菜单(带预览图片)切换主题了。

    1. @Cloudream
      哈哈,不好意思~~
      说了句不太负责任的话。
      赶紧改一下,以免造成更多坏影响~

  2. @皮蛋
    这个不是错,只是逐步将会被废弃所以不推荐而已。
    只是到了1.3以后就真的会出错了……

  3. 教程的问题,嗯……的确我已经很久没更新过了,按你的提醒,我现在作了少许标记,如有问题可直接email给我,多谢!

发表评论